Bursar's Office
A. Zachary Yamba Building; Room 4121
303 University Ave.
Newark, NJ 07102
Phone: (973)877-3099

Minimum Browser Requirements for Online Payments

The Minimum Browser Requirements for payments are as follows:

Internet Explorer 8.0 or later
FireFox 8.0 or later
Safari 5.1 or later

 

To Check the Version of your Browser

 

Internet Explorer
1. Go to the Help Menu
2. Click on About

NOTE: If you are updating your Browser make sure to check your system’s minimum requirements and Operating System.

To update Internet Explorer go to
http://windows.microsoft.com/en-US/internet-explorer/downloads/ie-9/worldwide-languages

 

If you are using Internet Explorer 8 or 9 as your browser and a blank screen is displayed when attempting to make a payment, Click  on the Compatibility View Icon next to the  web address bar as shown below.

 

Mozilla FireFox
To Check the Version of Mozilla FireFox Browser
1.Click on Firefox
2. Go to the Help Menu
3. Click on About Firefox

The About Mozilla Firefox window will appear. Your version number is listed underneath the Firefox name.

NOTE: If you are updating your Browser make sure to check your system’s minimum requirements and Operating system.
To update to the latest version of Mozilla Firefox go to http://www.mozilla.com/firefox

 

Safari
To check the Version of the Safari browser installed on your system
1. Go to the General Settings menu option. Click the drop down arrow next to the General Settings menu and select About Safari from the list of available menus.

 

NOTE: If you are updating your Browser make sure to check your system’s minimum requirements and Operating System.

To update Safari go to: http://www.apple.com/safari/download/

 

If your computer meets all the Minimum Browser Requirements and you still encounter a problem after selecting the Compatibility View,  please feel free to visit our Open or Self-service ECC Labs.